# 2.13 Perl 安装说明

2.13.1 在 Unix 上安装 Perl

2.13.2 在 Windows 上安装 ActiveState Perl

2.13.3 使用 Perl DBI/DBD 接口的问题

PerlDBI模块为数据库访问提供了一个通用接口。你可以写一个DBI无需更改即可与许多不同的数据库引擎一起使用的脚本。使用DBI, 你必须安装DBI模块,以及您要访问的每种类型的数据库服务器的数据库驱动程序 (DBD) 模块。对于 MySQL,此驱动程序是DBD::mysql模块。

笔记

Perl 支持不包含在 MySQL 发行版中。您可以从以下位置获取必要的模块http://search.cpan.org (opens new window)对于 Unix,或使用 ActiveStateppmWindows 上的程序。以下部分描述了如何执行此操作。

DBI/DBD接口需要 Perl 5.6.0,最好是 5.6.1 或更高版本。DBI不工作如果你有旧版本的 Perl。你应该使用DBD::mysql4.009 或更高。尽管有更早的版本可用,但它们不支持 MySQL 8.0 的全部功能。